• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


stock

Trouble Installing Aftermarket Stereo

3 posts in this topic

i have the new facis and stereo unit with adapter socket to the double din but when i connect them up the stereo has no power any ideas anyone?

Share this post


Link to post
Share on other sites
 

i have the new facis and stereo unit with adapter socket to the double din but when i connect them up the stereo has no power any ideas anyone?

i managed to get it working by wiring both the 12v and 12v switched together but stereo wont switch off now

the problem is the live 12v not 12v switched wire as the 12v wire in the adapter plug has no connection in the smax wireing block in other words where the 12v red wire pin is in the adapter there is no wire on the corresponding smax block and i dont know which wire would be the 12v feed wire so if anyone knows which it would be it would be most helpfull

Share this post


Link to post
Share on other sites

.... any ideas anyone?

Yes, don't fit rubbish aftermarket stereos.

Fit a proper ford Blaupunkt NAV unit.

200% better and no wiring issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now