TRAXXAS58

LED DRL Randomly Cuts Off

Recommended Posts

I have a 62 plate Fiesta with LED DRLs & I noticed in the reflection of the back of other cars that the right hand side LED strip was sometimes not turned on, after a few months & trying to check in reflections, I've come to the conclusion that it only seems to cut off after I've signalled right. 

 

It comes back on every time without fail simply by turning the engine off & back on again but nothing else seems to get it back on, changing types of light settings doesn't fix it. 

 

Anyone have any clue what this might be & any potential fix? Been bugging me for a while now! 

Share this post


Link to post
Share on other sites

I don't know the answer.  If you put the left indicator on, does the left DRL turn off whilst the indicator is flashing and come back on once the indicator is turned off?   would that car have had LED DRLs when new? it sounds quite early to have had LED DRLs originally

Share this post


Link to post
Share on other sites
4 hours ago, isetta said:

I don't know the answer.  If you put the left indicator on, does the left DRL turn off whilst the indicator is flashing and come back on once the indicator is turned off?   would that car have had LED DRLs when new? it sounds quite early to have had LED DRLs originally

The LED DRL dim themselves whilst the indicator is on, only the right side one ever goes fully off. 

It is an actual Ford thing, I do believe it was an optional extra to have LED DRL but it is an option direct from Ford. 

Share this post


Link to post
Share on other sites

Problems like that can be caused by bad Earthing. I don't know if they share a common Earth or not, or where it is located, but my first course of action would be to take the Headlight units out and if you find an Earthing point then take it off and clean it.

Share this post


Link to post
Share on other sites

Do you have a Titanium / X model? I didn't think that the 62 plate Fiesta's had LED DRL as standard or optional extra other than the Tit/Tit X models. I had a 14 plate Zetec which still had standard bulbs for DRL. I vaguely recall LEDs becoming standard a year or so later.

Share this post


Link to post
Share on other sites
14 hours ago, Zico said:

Do you have a Titanium / X model? I didn't think that the 62 plate Fiesta's had LED DRL as standard or optional extra other than the Tit/Tit X models. I had a 14 plate Zetec which still had standard bulbs for DRL. I vaguely recall LEDs becoming standard a year or so later.

It's a Titanium. 

Share this post


Link to post
Share on other sites

@TRAXXAS58 have you tried @Tizer's suggestion? Unfortunately I can't offer any more help myself other than checking if the wiring is ok. Might be worth checking out the cost for a replacement headlight as I believe even if in warranty, the LED DRL is non-serviceable.

Share this post


Link to post
Share on other sites

I have a 13 plate titanium and it has LED DRLs.

 

Share this post


Link to post
Share on other sites

Checked this morning and the DRLs do dim on the side that the indicator is working on,

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.