Jump to content


Show
Photo

Ghia Centre Cap Fix?


  • Please log in to reply
2 replies to this topic

#1 jon-v8

jon-v8

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 64 posts
  • Name: Jon
  • Ford Model: Focus Ghia Estate
  • Year: 2006
  • Location: Devon

Posted 19 November 2012 - 08:41 PM

The centre caps on my ghia alloys are all loose.

I had the wheels off a couple of weeks back to clean them along with the arches (only had the car a month), and after removing the caps to remove the wheels, i noticed they had been held in with some black gunky type of glue?

None of the clips appear to be broken?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 RickG

RickG

    Settling In Well

  • New Member
  • PipPipPip
  • 55 posts
  • Ford Model: Focus Estate Econetic
  • Year: 2008
  • Location: Cheshire

Posted 20 November 2012 - 01:12 PM

This was a problem when I took my wheels off my ghia. I just spread the metal clips that hold the caps in.

#3 jon-v8

jon-v8

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 64 posts
  • Name: Jon
  • Ford Model: Focus Ghia Estate
  • Year: 2006
  • Location: Devon

Posted 20 November 2012 - 03:25 PM

Thanks. I did try that, but didn't want to bend the metal too far due to the plastic clips looking a little fragile.

I'll give it another go and see how I get on...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users