Ford Owners Club - Ford Forums Messages

FORD FAIR – SILVERSTONE – 6TH AUGUST 2017

Join us on the Ford Owners Club stand at Ford Fair, Silverstone on Sunday 6th August 2017.

Click this link to find out more

    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
peterg

1996 fiesta with NO brakes!!!!

2 posts in this topic

Recently we changed the clutch ratchet and having got that working test drove the car the clutch was perfect BUT the brake pedal was soft and useless. To the best of my knowledge we took a clip of something protruding out of the brake pedal as said in the Haynes manual and replaced it. Logic tells me that I have not reassembled it properly but cannot see what is wrong. It certainly is not the hydraulics / servo.

Any ideas??

Cannot find a blow apart diagram for the brake pedal assembly anywhere.

Thanks

Peter

Share this post


Link to post
Share on other sites
 

Sorted..someone? undid the bolts holding the long bar that traverses the engine to the hydraulics. Result was as you pressed the pedal the bar moved forward and the hydraulics were not compressed.

Ten minutes of frantic nut tightening and we were fixed. A case of too many cooks spoiling the broth!!!

Recently we changed the clutch ratchet and having got that working test drove the car the clutch was perfect BUT the brake pedal was soft and useless. To the best of my knowledge we took a clip of something protruding out of the brake pedal as said in the Haynes manual and replaced it. Logic tells me that I have not reassembled it properly but cannot see what is wrong. It certainly is not the hydraulics / servo.

Any ideas??

Cannot find a blow apart diagram for the brake pedal assembly anywhere.

Thanks

Peter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0