Jump to content


Photo

Dashboard Indicators & Heated Front Windscreen Problems


  • Please log in to reply
3 replies to this topic

#1 Smittie

Smittie

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Focus

Posted 17 April 2010 - 04:33 PM

Ford Focus 2003 lx

On the dashboard the Battery light indicator comes on after 20 - 30 seconds

& Brake/Handbrake light indicator is intermittent

Heated front windscreen works ok on start up until the battery light indicator shows

The Battery and Alternator have been checked twice also I have cleaned the cluster board behind the dashboard with Electrical cleaning spray.


Still getting the problems, hope you can help?

Reply to Artscot79
I Have Checked the Battery type its a MotorCraft SuperStart 12volt 390Amp EMF 543025039w not sure if is a Silver Calcium battery?

Update 18/04/10
Changed my Battery to a Bosch Silver Calcium still getting the dashboard faults?


Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 artscot79

artscot79

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 7,938 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 17 April 2010 - 05:49 PM

Ford Focus 2003 lx

On the dashboard the Battery light indicator comes on after 20 - 30 seconds

& Brake/Handbrake light indicator is intermittent

Heated front windscreen works ok on start up until the battery light indicator shows

The Battery and Alternator have been checked twice also I have cleaned the cluster board behind the dashboard with Electrical cleaning spray.


Still getting the problems, hope you can help?



simply check youre battery if its a lead acid battery its the wrong type it must be silver calcium/lead calcium battery due to the smart charge which over time toasts normal batteries and gives you the kind of issues youre having right now most places dont have a clue about the battery or th esmart charge if you went to ford youde find that they will sell you silver/lead calcium battery whereas because they are cheap most places such as halfords will recommend lead acid batteries if yiou have the correct battery then you will neeed to take it to ford who will cjheck it and if they find a cluster fault have to replace it at a cost of 99 pouinds

#3 hawker

hawker

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 217 posts
  • Ford Model: 2006 Focus 1.6 TDCi
  • Location: Cardiff

Posted 17 April 2010 - 08:55 PM

I had exactly the same problem with mine.
Your alternator is gone mate. Get it checked again elsewhere
Probably looking around £200 to fix

#4 artscot79

artscot79

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 7,938 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 17 April 2010 - 09:01 PM

Your alternator is gone mate. Probably looking around 200 to fix



check the battery first many a car has had new alternators with these symptoms to find they still exist if its a lead calcium or silver calcium battery then have ford test the alternator properly if its a lead acid battery get the proper battery first


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users