Jump to content


Photo

Focus 2.0L Performance


  • Please log in to reply
1 reply to this topic

#1 CherryPie

CherryPie

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Focus Ghia 2.0l

Posted 01 March 2011 - 04:15 PM

Hello

Does anyone here have a Focus 2.0l 06 plate, petrol?

If so, what do you think of the performance (0-60)? I'm asking because I'm a little concerned there may be something wrong with my car.

It feels so sluggish considering it's a 2.0 and 143bph! When I pull away from junctions, giving normal gas, there's just no umph at all. It's not that I'm a girl racer or anything, but it just doesn't feel right to me. I have 1.0 Nissan Micras up my rear because I'm crawling to get up to 30mph.

All this, and yet I'm getting 25-30 mpg combined!

Sorry, I know I sound whiny. I think I just feel a bit cheated. The fuel economy is right for the engine size, but I'm getting 1.0l performance.

To give some comparisons, my previous car was a SportKa, which felt much nippier than my Focus, even though the Sportka is supposed to be 0.5 second slower 0-60.

I used to have an Audi 2.0l 145bph, which felt in a different league performance wise. Really my Focus should be similar to that, but it is nowhere near.

If that's just the way the car is, then fair enough, but if other people's Focus's are quicker, then perhaps I'll take it into the dealership.

Thanks for reading and sorry for whining!

CP

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 Pete80

Pete80

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 261 posts
  • Name: Peter
  • Ford Model: Ford Mondeo Titanium X
  • Year: 2007
  • Location: Warwickshire

Posted 02 March 2011 - 02:41 PM

To be honest it sounds like you have a problem with it, I have the 2.0 diesel and it flies, also I have drove my mates 2.0 petrol focus and it doesnt hand around either. When was the last time it was serviced? Are the tyres inflated to their proper pressure? Possible sensor failure ? Its possible that the brakes are binding and causing performance issues? If you have a warranty of some kind I would definitely get the dealer to have a thorough look at it.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users