Jump to content


Show
Photo
- - - - -

Rear Window heater + Fog Lights


  • Please log in to reply
2 replies to this topic

#1 Phil C

Phil C

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: Fiesta
  • Location:

Posted 02 December 2008 - 03:42 PM

Ok so my rear window heater (the grid) and my fog lights are completely broke. Although both the fuses are fine so obviously I'm thinking it's a switch or relay.

Where would I find these relays/switches on a 1998 fiesta 1.25 zetec? :) My fog light button works when I press it but no fog lights come on, even after I've changed the bulbs. Same with the rear window heater, the light on the button comes on but the grid does not work.

Help appreciated, thanks :)

Phil.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,462 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 02 December 2008 - 06:13 PM

have you checked/cleaned the connections near the tailgate hinge it the source of problems

#3 Phil C

Phil C

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: Fiesta
  • Location:

Posted 02 December 2008 - 06:51 PM

have you checked/cleaned the connections near the tailgate hinge it the source of problems


On the actual grid? Yes I've noticed one is different to the other


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users