Jump to content


Photo

2007 Focus 1.6 Tdci Problems...


  • Please log in to reply
4 replies to this topic

#1 foo_addict

foo_addict

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: Adam
  • Ford Model: Focus
  • Year: 2007
  • Location: Gloucestershire

Posted 02 September 2011 - 05:44 PM

Hi all,

On a recent trip the car started making a funny noise. It sounded as if it was coming from the radiator/intercooler area. The noise kicked in all of a sudden and would stay present whilst the radiator fan was running after the ignition was switched off. Took a short video of the sound on my phone while it was held in front of the grill at the front of the car, please listen at the link below...



Took the car to my local dealer today and they did some checks and said the Turbo has gone. I have no other problems other than this sound that has happened two or three times in the last couple of weeks

The garage says that they can fit a new turbo but it will most likely blow again in a month or two - they say only a completly new engine and turbo will fix it.

Is this something anyone has heard before? If the turbo was that broken would I not be suffering loss of power?

The car is a 2007, has only covered 34k and has full ford service history.

Any advice appreciated,

Adam

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 Leemaxd

Leemaxd

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 276 posts
  • Ford Model: Focus zetec s

Posted 02 September 2011 - 05:59 PM

Whole new engine that's mad, have you taken it to various garages for a quote ?

#3 foo_addict

foo_addict

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: Adam
  • Ford Model: Focus
  • Year: 2007
  • Location: Gloucestershire

Posted 02 September 2011 - 06:12 PM

Not yet, but will be 5-6k at this dealer for new engine + turbo.

Apparently there is 'swarf' in the engine from the faulty turbo that (in most cases) even an engine flush will not completely remove!

#4 Karlos

Karlos

    Settling In Well

  • New Member
  • PipPipPip
  • 43 posts
  • Ford Model: Focus Titanium 2.0 TDCi - Remapped

Posted 02 September 2011 - 08:57 PM

Sounds a bit dodgy to me. Surely if the noise is still present whilst the fan is running but the engine is off, then it's a problem with the fan?

#5 dreadz

dreadz

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 126 posts
  • Name: A
  • Ford Model: focus
  • Year: 2007
  • Location: Cornwall

Posted 03 September 2011 - 07:32 AM

i agree if the engine is switched off, then cant be engine fault/turbo as they cease to run after stopped!!! sounds like bearing on something- radiator???

get a 2nd opinion mate-definately not engine related!


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users