Jump to content


Show
Photo
- - - - -

Few Questions About Mk5 Fiesta


  • Please log in to reply
3 replies to this topic

#1 sk8te-penguin

sk8te-penguin

    Newbie

  • Members via FB
  • Pip
  • 4 posts
  • Name: Aaron
  • Ford Model: 1.3 MK 5 Fiesta Flight
  • Year: 2001
  • Location: Yorkshire

Posted 17 January 2013 - 09:55 PM

Hey guys, just got a few questions about my MK5 Fiesta (MK 4 facelift in other countries)

1) What size is the rear wiper? Mine was missing when I bought it so... Yeah.

2) It's the 1.3 endura-e engine, how many miles should I get to a full tank?

3) It's done 74.5k ish miles, when should I expect to need to replace the front wheel bearings and driveshafts?

4) The gear change into 1st is getting a little difficult/rough, is this normal at this mileage?

5) It doesn't have the boot lid spoiler as standard, how easy is it to fit one? (The standard ford unit, not some chavy wail tail)

6) The power steering has 2 wires going to it that are clearly visible. My dads never had a car with power steering so we aren't sure if it's the pump or sensor wires. One of the two wires has either been cut or has just fallen off, but everything works okay and there are no warning lights on the dash. Help?

7) I would like a rev counter and an engine temp guage, how hard is it to find/fit these?

Thanks :)

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Dan62

Dan62

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 395 posts
  • Ford Model: Fiesta
  • Location: London
Contributor

Posted 18 January 2013 - 03:24 PM

4) You could try checking / topping up or changing the gearbox oil, is it just a problem getting into 1st when the car is moving ?

6) the only wires I've ever noticed on the power steering was on my old jeep, it was a pressure switch which activated when the car was on full steering lock and the pump strained, the switch increased the engine rpm to stop it stalling.

#3 sk8te-penguin

sk8te-penguin

    Newbie

  • Members via FB
  • Pip
  • 4 posts
  • Name: Aaron
  • Ford Model: 1.3 MK 5 Fiesta Flight
  • Year: 2001
  • Location: Yorkshire

Posted 20 January 2013 - 11:29 PM

It's when I've stopped moving and it's only in 1st gear and it seems to be an intermittent problem but thanks :)

#4 sambooka

sambooka

    Sam Oglesby

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,024 posts
  • Name: sam
  • Ford Model: mk7 fiesta tdci zetec s
  • Year: 2011
  • Location: Lincolnshire

Posted 21 January 2013 - 12:34 AM

4.is it the complete arm that's missing or just the blade


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users