• Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


hammerdw

Fiesta Zetec S Sony Dab Radio Not Working

7 posts in this topic

I have a 2011 ford fiesta which had a standard ford radio, i have changed this for a sony dab and had been told i would need a new dab aerial which i have fitted. the radio is working with both aerials plugged in but the menu does not show the dab options. does anybody have any ideas?

Share this post


Link to post
Share on other sites
 

You'll probably need to do a software update aswel. Ps welcome to the club

Share this post


Link to post
Share on other sites

Hi

Thank you for the response.

I have tried the update via official ford download with usb but it will not run the update

I can see this is a very common problem - just wondered if anybody has found a solution

Many thanks

Here the radio thats in my car and it got to ariel ports on the back.

post-44591-0-10275300-1372254080_thumb.j

post-44591-0-95719500-1372254116_thumb.j

Share this post


Link to post
Share on other sites

Your dealer must enable the DAB function with the IDS computer.

It is not that easy, I fitted the Sony DAB radio (AA6T-18C815-XG) and my dealer could change the settings but the onboard computer changed it back as soon as the settings were confirmed.

My dealer told me that they need the specific asbuild data from a fiesta with a factory fitted Sony DAB.

Over here in the Netherlands the Sony DAB was never a listed option, so my Sony DAB project is dead. :(

Share this post


Link to post
Share on other sites

I have this problem, do you get FM radio with it?? I've just plugged mine into the standard Ariel but I haven't had any luck?

Im not bothered about DAB

Thanks

Share this post


Link to post
Share on other sites

It's a really old thread Dan...you might not get a reply from them

Sent from my iPhone using Ford OC

Share this post


Link to post
Share on other sites

oh yeah :( gutted thought I may have found the solution..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now