Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
mkj

Brake Lights

4 posts in this topic

Hi,

My side rear brake lights don't work. The brake-stripe light works ok.

Have checked the fuse's all seems ok, checked the bulbs they are ok,

now Im baffled?

Can anyone suggest anything else.

Regards

mkj

Share this post


Link to post
Share on other sites
 

Do the tail lights work? They use the same 5/21W offset bulbs.

The fuse you should have checked is #42 (15A).

Share this post


Link to post
Share on other sites

check wireing at tailgate hinge for breaks.

Share this post


Link to post
Share on other sites

Thanks for advice.

Who ever put the bulbs in, put the wrong ones in.

Changed bulbs, now working OK.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0