grandads_shed

Engine Malfuntion And Black Smoke 2 Minutes ??

Recommended Posts

2010 mondeo titanium x diesel

driving out of town today at 60mph, 6th gear using cruise control, all of a sudden i got a engine malfunction message on my dash -board and then black smoke from the exhaust,

pulled over to the side of the road and turned the engine off, waited a couple of minutes the turned ignition to on position to check engine temp. malfunction message had gone and everything seemed fine , so restarted the car, bit of black smoke from exhaust which cleared within seconds ,

carried on with my journey for the last 25miles with out any thing else happening and car drives as normal ,

oh and the "average fuel" monitor said that i was getting 99 miles per gallon for about 5 miles,

im starting to think that it was a hiccup and that the engine got more fuel than it should have got. then was fine after everything was reset after turning ignition off then back on..

or could it have been something to do with the dpf filter in the exhaust cleaning itself ??

Share this post


Link to post
Share on other sites
 

that to me suggests either you choked up on air, and overfuelled, or you possibly had an EGR issue. If the EGR for some reason stuck closed, and was called upon then all of a sudden it opens the pressure backlog could have blown a load of carbon through and blown the entire combustion cycle out of whack...

Share this post


Link to post
Share on other sites

nope the car was still running by the time i pulled over the side of the road ,, cars been running fine ever since then

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now