Jump to content
Do Not Sell My Personal Information


Ford galaxy automatic - transmission limited function


Fishcake1552
 Share

Recommended Posts

I have a 2010 ford galaxy titanium with automatic gear box.  A couple of times an error message saying 'transmission limited function' has come up on the dash when the car is stationary and the car won't then reverse.  On both occasions it's righted itself when the engine has been turned off and on again.

i was driving to work the other day and the warning sign came on whilst I was driving and the car sounded like it couldn't find a gear.  I had to pull over and turn the engine off and on again, it again righted itself once the engine was turned back on.

it was put onto diagnostics which revealed no error codes and they're suggesting we have the gearbox stripped at a cost of £500 plus.

any ideas what could be wrong?

thank you

Link to comment
Share on other sites

  • 2 weeks later...

  • 1 year later...
  • 3 years later...

Thought I'd just share this with you.

I've got a Galaxy Powershift 2013 bought 3 yrs ago with 57k on it, transmission fluid changed at 50k, just recently with 76k it started playing up with the revs fluctuating, jerky gear changes & limited transmission warning mainly going up hill, garage did transmission fluid change & filter 7 months ago, still same problems, said it would be transmission out at a cost, thought I'd try an alternative first SEAFOAM TRANSTUNE syringed out same quantity before adding, says drive 100 miles before fluid change, bought Westway Lubricants Powershift fluid with filter at £90 added another SEAFOAM at £17, drove the same for 2 months 600 miles when suddenly the transmission started working as it should, can't believe,was about to part ex the car, this has saved me a fortune, been driving ok now for 2 weeks 😃 

Link to comment
Share on other sites

  • 3 weeks later...
On 6/7/2021 at 6:44 AM, Chuckster said:

Thought I'd just share this with you.

I've got a Galaxy Powershift 2013 bought 3 yrs ago with 57k on it, transmission fluid changed at 50k, just recently with 76k it started playing up with the revs fluctuating, jerky gear changes & limited transmission warning mainly going up hill, garage did transmission fluid change & filter 7 months ago, still same problems, said it would be transmission out at a cost, thought I'd try an alternative first SEAFOAM TRANSTUNE syringed out same quantity before adding, says drive 100 miles before fluid change, bought Westway Lubricants Powershift fluid with filter at £90 added another SEAFOAM at £17, drove the same for 2 months 600 miles when suddenly the transmission started working as it should, can't believe,was about to part ex the car, this has saved me a fortune, been driving ok now for 2 weeks 😃 

Just an update, covered 500 miles now since the transmission started working like it should, even been on the motorway with no problems, I would definitely give Seafoam a try first, a must if your car is going into limp mode, limited transmission & revs fluctuating & can't decide which gear to go in & jerky gear changes, be patient though it does take time for Seafoam to work 

Link to comment
Share on other sites

  • 3 weeks later...

Hi all, just a thought on the Galaxy Powershift shift problem, you hear about swarf getting stuck to the solenoids & the only way to clean them is to remove the transmission, but I'm told the the Powershift has a wet clutch so as that wears the clutch material is contaminating the transmission fluid that why it turns black & also could cause problems with the solenoids,so that's more likely the reason why you need to change it at 40k

Link to comment
Share on other sites

  • 4 months later...
On 6/28/2021 at 4:30 PM, Chuckster said:

Just an update, covered 500 miles now since the transmission started working like it should, even been on the motorway with no problems, I would definitely give Seafoam a try first, a must if your car is going into limp mode, limited transmission & revs fluctuating & can't decide which gear to go in & jerky gear changes, be patient though it does take time for Seafoam to work 

Hi mate did you put the sea foam in transmission oil ? I’m having the same issue with my ford s max. So just need advice what to do ? If you can give any advice where to add sea foam and how you did it that will be great. 

Link to comment
Share on other sites

On 6/7/2021 at 6:44 AM, Chuckster said:

Thought I'd just share this with you.

I've got a Galaxy Powershift 2013 bought 3 yrs ago with 57k on it, transmission fluid changed at 50k, just recently with 76k it started playing up with the revs fluctuating, jerky gear changes & limited transmission warning mainly going up hill, garage did transmission fluid change & filter 7 months ago, still same problems, said it would be transmission out at a cost, thought I'd try an alternative first SEAFOAM TRANSTUNE syringed out same quantity before adding, says drive 100 miles before fluid change, bought Westway Lubricants Powershift fluid with filter at £90 added another SEAFOAM at £17, drove the same for 2 months 600 miles when suddenly the transmission started working as it should, can't believe,was about to part ex the car, this has saved me a fortune, been driving ok now for 2 weeks 😃 

Hi  mate did you put the sea foam in transmission oil ? I’m having the same issue with my ford s max. So just need advice what to do ? If you can give any advice where to add sea foam and how you did it that will be great

Link to comment
Share on other sites

  • 3 months later...
On 12/9/2021 at 11:16 PM, Rahul Raval said:

Hi  mate did you put the sea foam in transmission oil ? I’m having the same issue with my ford s max. So just need advice what to do ? If you can give any advice where to add sea foam and how you did it that will be great

Yeah if you remove the air box, just underneath you'll see a flat headed 8 mm Allen key bolt on the front right side, you can add seafoam from there.

I've had problems with mine again, had to renew the transmission oil again, noticed small hard black specs in it on draining, must be from the clutch, my mechanic friend said it's what the seafoam has cleaned out

Link to comment
Share on other sites

  • 5 months later...
On 5/25/2016 at 10:42 PM, Fishcake1552 said:

I have a 2010 ford galaxy titanium with automatic gear box.  A couple of times an error message saying 'transmission limited function' has come up on the dash when the car is stationary and the car won't then reverse.  On both occasions it's righted itself when the engine has been turned off and on again.

i was driving to work the other day and the warning sign came on whilst I was driving and the car sounded like it couldn't find a gear.  I had to pull over and turn the engine off and on again, it again righted itself once the engine was turned back on.

it was put onto diagnostics which revealed no error codes and they're suggesting we have the gearbox stripped at a cost of £500 plus.

any ideas what could be wrong?

thank you

 

Link to comment
Share on other sites

Hi I have the same problem as your self I been told it could be that u need to change the gear box oil and filter or if it sounds like it suckling in air it could be vacuum pipe broken or it could be that the gear box may need to be programmed again but I can let u be by tomorrow some time as I am going ti get a Diagnostic done tomorrow and I will no  what may be the problem 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership