Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


3 posts in this topic

Hi all,

This is my first post, and im just wondering something......

I have a 2009 (09) 1.6 TDCI.

Ive heard lots of horror stories about the turbos failing on the engine due to the engineering between the hoses, the sump and the turbo (its the same as in the mini, pug hdi, citroen etc ive been told?) From what ive read it seems that they are "garrett" (if ive spelt right) turbos.

However.....

After looking at my engine and turbo, nowhere does it state garrett on the turbo body it just states various numbers.

Also there are marks on the bolt heads and bolt housing, where it looks to me they have been marked for the correct torque settings for when the turbo unit is removed and put back on.....Why would someone do this for a car with 23k on the clock?

Ive taken a photo so you can see (i hope its right size etc for the forum as i dont know how to scale it)

Also do the new TDCI units still suffer with this problem of turbo failure, as again when reading i get mixed responces. Some people say yes but only on focus and others say no, it was rectified on the MK7, and then there are people who say yes the turbo fails on all TDCI's

Please help/advice

Cheers

Liam

7481023692_ed6a3549ac_c.jpg

Share this post


Link to post
Share on other sites
 

the markings are done when it is first assembled, so they know they did the bolt up, they will be all over the car

Share this post


Link to post
Share on other sites

the markings are done when it is first assembled, so they know they did the bolt up, they will be all over the car

cheers, i was just wondering if someone else had done it post factory.

Well it drives fine, and i spoke to a mechanic who recommends an oil service every 6 months outside of guidlines just to be safe (and for £25 i think its worth it!)

Beautiful fiesta fordpartsman! :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now