• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience


mrHman

Help Fitting Mk1 Mudflaps

6 posts in this topic

Hey ppl, installed my genuine ford mudflaps today for the rear with no issues. However I need help with the fronts...the metal clips just keep sliding off whenever I fix them on. E.g. if I move the mudflap then it will slide off....not sure if im doing it right.....anyone got any guides or pictures?

Share this post


Link to post
Share on other sites
 

bash the clip off the car with a hammer so its a snug fit before tightening the bolt

Share this post


Link to post
Share on other sites

i tried that but that damned clip just keeps sliding off...Its not like the rear which has more metal on the body to clip onto. It has a really thin (prob 1cm) of metal around the wheel arch for the clip to hold on to.

Share this post


Link to post
Share on other sites

i had the same issue i had to bend the clip so the two points were almost touching at the front then attatch otherwise it will keep sliding off

Share this post


Link to post
Share on other sites

Thanks followed ur advice and now it fits properly

Share this post


Link to post
Share on other sites

took me ages to figure that out the first time round till i realised all the clips were set to the size needed for the rear wheres theres more to grab onto i must have refitted them half a dozen times before realising lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now