Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


pagdodd

Titanium X Business Edition Dab Problem

142 posts in this topic

FYI folks. Since the last time mine went in, I have not had any issues with my DAB. So whatever they did, it worked :-)

Share this post


Link to post
Share on other sites
 

Had my car in today about the dab radio issue.

Software update required & all is well now.

Will let everyone know how long it lasts.

Cheers. Paul.

Share this post


Link to post
Share on other sites

Just had the same happen on mine (Had it from new from March 2014)

You press the DAB button and it stuck on Talksport (just to tease me!) but no sound, you cant tune, list or do anything with it! When you go to tune it defaults to FM.

Now I have looked at these post I am now armed as it is booked in on Monday to have it looked at.

Watch this space!

Share this post


Link to post
Share on other sites

I thought my problems were over! But two days ago, it stopped working again!

Rebooked in to Ford for next Friday....

Share this post


Link to post
Share on other sites

I have just encountered the same problem a few days ago... DAB suddenly stopped working after buying my nearly new car about 5 months ago. Glad I found this article, thanks everyone for their contributions... a lot of useful information here. Will get mine booked in the garage and report back how I get on.

Share this post


Link to post
Share on other sites

I'm new to FOC and am not sure if this topic is still active as the last post was August 2014. My Mondeo Titanium X BE is 8 months old and last week the DAB radio stopped working. It was around the same time that I connected my iPhone to the USB socket for the first time. The car went back to the dealer yesterday. They agreed that there is a fault but said that nothing could be done pending a resolution /recall coming from Ford. They couldn't tell me when this would be available. When I pointed out that this problem has been around for well over a year (ref this forum) and that other owners had had the same fault rectified they said that in the past they had carried out software updates and fitted new components but were now instructed not to. I was shown the "broadcast " covering the issue. After complaining I was told that it was outside the dealers control and I would have to speak to Ford. I did that and now have a case number. Ford spoke to the Dealer who confirmed that they had done nothing more than read the "broadcast " but would now phone the Ford technical expert for advice. I'm waiting for that feedback. I use DAB all the time and it was one of my key requirements when I chose the car. Can anyone offer advice or experience please. Sorry for the long post

Share this post


Link to post
Share on other sites

I have not heard anything about a recall but can confirm that my DAN is fully functional since I tool my car in for the 3rd time (about 3 months ago)

Would be interested to know what they are going to do IF they do a recall.

Whilst I like the unit fitted in my Mondeo, it feels like it is due a software update as it feels a little dated.

for example: scrolling text on track names would be very nice

Share this post


Link to post
Share on other sites

*DAB

Share this post


Link to post
Share on other sites

Well I'll update this thread when I get more information but at present I get the feeling that both the Dealer and Ford are going to leave me wanting for a fix from Germany for an unspecified time so next week I'll start looking into my legal position with respect to the warranty.

Oh I can now see some more recent posts. Sorry didn't see those before.

Share this post


Link to post
Share on other sites

Took mine to the garage and they said they tried to reset it but it did not fix the problem, so they had to book it in for a second time to do further investigations and they would contact technical support to help diagnose the problem. When I took it there the second time they did a hard reset but couldn't do anything else as they didn't have the radio code. I picked it up, entered the radio code and the 'hard' reset had fixed the problem... been working fine now for the last few months.

The garage I used was rubbish and really unhelpful... I suspect the first time they did nothing and the second time they just disconnected the car battery. No software update for me and I would say my problem was a software problem as been fine since it was all reset and they haven't changed any hardware. It does make me think though that the problem could happen again at any time! :-(

Share this post


Link to post
Share on other sites

Mine has now stopped for the second time.

14 plate car, first stopped around the first service, has just failed again at 42000 miles.

Was in for a service last week but the dealer was having issues with their ford service software, could not even reset the service indicator !

Will be going back to them in a week for another go....

Good job it's a company car, would be really !Removed! otherwise, find also the DAB reception is terrible compared to the previous model.

Share this post


Link to post
Share on other sites

After numerous calls to the dealers service dept (who have adopted the stance that they can do nothing pending a fix from Ford) and to Ford Customer Relations (who are intent on referring back to the dealer) I have called the salesman who sold me the car and complained about breach of contract. I've asked what he's going to do about it and if they can't fix the problem I want my money back. We'll see what happens

Share this post


Link to post
Share on other sites

It sounds as though most owners here can't tune their DAB. My problems a little different in that the DAB element of my radio has completely disappeared!

Has this happened to anyone else and if so, have you managed to get it back?

Share this post


Link to post
Share on other sites

Pull the fuse or disconnect the battery for 10 minutes to reset the syatem.

Brettania likes this

Share this post


Link to post
Share on other sites

I think most members posting on this topic have the same problem as me. When selecting the DAB option within the radio menu, the stored channels appear, but none of them can be selected i.e the channel will not stay highlighted and there is no sound. Mine failed at under 8000 miles. Ford Customer Services are phoning me each week but it's now 4 weeks since the fault developed and they can't tell me when the software solution might be available or indeed how long Ford have been working on it. I have now written to the Dealer who sold me the car to exercise my rights under the Sale of Goods Act. I have asked them to repair it within 7 days and if they can't I want them to take the car back and give me a refund. They phoned me today and said that they can do nothing until Ford produce the software fix. They admitted that these faults have existed for a long time but insist that the radio works except for the DAB part and that I am being unreasonable. They say that they will not take the car back for such a minor issue. I am taking legal advice and believe that I have a good case in law...we'll see. If I do nothing I will be waiting indefinitely and have no leverage to get the radio fixed. In my case I only ever listen to the DAB channels so this is a real pain.

Share this post


Link to post
Share on other sites

Thanks Stoney871. I'll give Ford a bit longer to come up with a permanent solution before I try the re-boot option. When I first took the car back to the dealer one of the service guys told me that in the recent past they had fixed a number of identical faults by changing components and resets but now they are instructed not to do these repairs so I'm not sure what's going on

Share this post


Link to post
Share on other sites

Thanks Stoney871. Disconnecting the battery for 10 mins worked perfectly. Took me a few mins to find the security code to get things working again, after that my DAB was back! Many thanks.

Stoney871 likes this

Share this post


Link to post
Share on other sites

ok so ive jsut got same problem today as others that DAB suddenly stopped working and this was one of reasons I purchased this car. I havent phoned dealers yet as thought I may try a fix myself.

Ive noticed people mention disconnect battery but at the moment I can not find the security code :-(

However can any one tell me how to do a hardware reset and a software upgrade please.

Thank you

Share this post


Link to post
Share on other sites

I didn't do the power down and power up option because I suspected that it wouldn't be a permanent solution and the fault could reoccurr (as some members have found). The dealer doesn't want to do anything as instructed by Ford and they feel that if they attempt any repair it could invalidate the warranty. The permanent solution is a software rewrite from Ford and I have been pressing both the dealer and Ford to come up with it. I had a feeling that Ford weren't going to bother, on the basis that they now had a new model of Mondeo so I eventually got the dealer to agree to take the car back and to give me a refund. At that point my car was 8 months old and I'd owned it for 3 months. While I was looking round for a new car (which incidentally confirmed that my car was a good deal in the first place) Ford phoned to say that the software they are working on should be available by mid August so I may well wait unless I find a good deal in the meantime.

Share this post


Link to post
Share on other sites

Im struggling to believe its a software issue, I purchased my 2013 car 3 weeks ago from AvailableCar.com worked fine until yesterday when i went on a long trip and suddenly stopped working.... im going to ring availablecar today see if they can say anything. Im also not happy with the MPG getting low 40s (worked out old way not trip computer) so its no where near the advertised figures!

Share this post


Link to post
Share on other sites

Well Ford think it's a software problem and when you think about it, it's only the digital part of the radio that stops working. Perhaps it's linked in some way to something else that the software controls. In my case the DAB failure happened at roughly the same time that I connected my iPhone to the USB port which maybe hadn't been done before.

As for mpg I agree it's disappointing. If I'm very careful I can get mine to around 53 mpg which is about 5 better than I got on the previous version of the same model. On paper the difference is 14 mpg. I've been looking at a Qashqai which is rated at 73mpg. Even the Nissan dealer told me to expect around 60. So clearly the quoted figures are under very ideal conditions and the gap with reality varies with the car manufacturer. There's a web site which gives data about the rated versus actual mpgs for different cars.

Share this post


Link to post
Share on other sites

Hi, I have a galaxy with the same radio but wanted to join the discussion as the same thing has just happened to mine.

I think that this is a software issue, mine stopped working whilst on a long journey, I initially had FM radio on then tried to change to DAB when away from home only to find that I could no longer tune in.

I think that the radio has issues with tracking the stations when moving away from your own area, I would be interested to know if anyone else had experienced the same issue, I know one person did for definite

Why it wont work when returning home I dont know, I just think disconnecting the battery removes the stations from the memory and you retune it, only for it to pack in again if you move away from your area.

What does anyone else think?

Share this post


Link to post
Share on other sites

Mine is off to Ford Garage on Tuesday under warranty for this issue. I took my car back to the garage I purchased it from yesterday and they couldnt fix it so they have booked it in at the local ford dealer for me. I'll update next week on the outcome...

Share this post


Link to post
Share on other sites

My DAB froze up so I pulled the fuse from the fuse box under the bonnet and put it back again, Making sure I knew what the key code was first, and it has started working again.

Share this post


Link to post
Share on other sites

Mine has been fine since the firmware update.

Got a reverse camera issue now. Oh well , the joys of owning a ford I guess.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now