Jump to content


Photo
- - - - -

Fiesta Zetec S Eco Boost Fuel Pump Problems

Problems Ford Fiesta Zetec

  • Please log in to reply
16 replies to this topic

#16 666Damian666

666Damian666

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 683 posts
  • Name: Damian
  • Ford Model: Fiesta ZS Ecoboost - MP135 Coming soon
  • Year: 2014
  • Location: Wiltshire

Posted 28 May 2014 - 08:28 PM

Not helping Matt, lol

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#17 Mellieha

Mellieha

    Newbie

  • Budding Enthusiast
  • Pip
  • 3 posts
  • Name: Brian
  • Ford Model: Fiesta Zetec S EcoBoost 125
  • Year: 2013
  • Location: Yorkshire

Posted 17 October 2014 - 08:46 AM

Just a little to add 'late in the day' on this. My '63 plate Zetec S had a noisy ('humming') fuel pump when bought (3,500m) in early March. Opted to run it 'til first service end-September even though dealer kindly offered at the time of purchase to investigate further if wanted. Just wanted to get out in the car and run it over the summer. Did not let me down but noise perhaps did get a little worse? At recent service the dealer ordered a new one; said it would arrive 'in about two weeks', arrived within nine working days and fitted immediately (6,500m). (A previous back-to-back comparison with two other Fiestas that had much quieter pumps had helped seal the matter). The new pump was as expected much quieter. Good honest service from dealership with no hassle. See how this one goes, fingers crossed!




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: Problems, Ford, Fiesta, Zetec

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users