Jump to content


Photo

White Screen Galaxy 55 Plate


  • Please log in to reply
2 replies to this topic

#1 irishbluestaffy

irishbluestaffy

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: john
  • Ford Model: galaxy
  • Year: 2005
  • Location: Cheshire

Posted 16 February 2012 - 12:46 PM

hi guys and gals, i have a problem with 1 of the screens in the headrest it is just white when turned on other 1 works perfect tried swapping still the same,so i would like to ask,how do i take the screen out the headrest if u can that is,second is where would i get another screen from,thanx.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 gregers

gregers

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 913 posts
  • Name: greg
  • Ford Model: smax titainium tdci
  • Year: 2008
  • Location: Sussex

Posted 16 February 2012 - 10:28 PM

try looking under the seat/s iirc there could be a connector to the screens there,perhaps 1 has come adrift?

#3 irishbluestaffy

irishbluestaffy

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: john
  • Ford Model: galaxy
  • Year: 2005
  • Location: Cheshire

Posted 16 February 2012 - 11:56 PM

try looking under the seat/s iirc there could be a connector to the screens there,perhaps 1 has come adrift?

iv swapped them and the good 1 works on it


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users