Jump to content
Do Not Sell My Personal Information


Big headaches


Vlad2111
 Share

Recommended Posts

Hello guys and thanks for having me. I have big issues with my Mondeo. Back in Feb I break down with message showing Stering malfunction. I picked the car on Saturday after all that time and yesterday the the car didn’t start. No messages on the display. I borrow one diagnostic tool from a mechanic and I have the faults in the pictures. After DTC is reset the car starts again. Can someone help me with what I have to do because I'm afraid I will be stuck somewhere again with the car not starting. Thank you 

E14C0A77-E8E1-49E2-90CE-AF61E5DA2C0F.jpeg

E1CA984B-9D24-471B-9F57-F359F2852BC8.jpeg

1C34C882-7BA3-452D-A64F-E3DD2101C737.jpeg

AA4239AD-9E24-4604-9A05-570ECA7422D1.jpeg

172A2556-3F5B-4AF5-9559-F4FADD4FA41C.jpeg

Link to comment
Share on other sites


Cant read the pics, too small. If it starts after clearing the Dtc's run it locally for a few days then see if any come back and go from there.

  • Like 1
Link to comment
Share on other sites

Also can’t read the pics. Would check alternator is charging. 

Link to comment
Share on other sites

Get yourself a code reader and keep it in the car so if it fails again and doesn't start you can clear the errors - gets you out of a hole! 

Link to comment
Share on other sites

far to small cant read them

Link to comment
Share on other sites


Here guys sorry for the poor pictures. I have a code reader but the car doesn't even go to contact just stays on the ford logo 

Link to comment
Share on other sites

3 hours ago, Vlad2111 said:

Hello guys and thanks for having me. I have big issues with my Mondeo. Back in Feb I break down with message showing Stering malfunction. I picked the car on Saturday after all that time and yesterday the the car didn’t start. No messages on the display. I borrow one diagnostic tool from a mechanic and I have the faults in the pictures. After DTC is reset the car starts again. Can someone help me with what I have to do because I'm afraid I will be stuck somewhere again with the car not starting. Thank you 

 

 

 

 

 

If you guys can help will be great

 

 

 

 

 

Link to comment
Share on other sites

 Vlad, for a start, get yourself a code reader that works! They aren't expensive.. 

Link to comment
Share on other sites

8 minutes ago, nicam49 said:

 Vlad, for a start, get yourself a code reader that works! They aren't expensive.. 

could you recommend a model I’m not that savvy when comes to cars. Thank you

Link to comment
Share on other sites

Well,  you really need one that runs a software called Forscan. I don't know what is available in your country tho', and since Brexit our dealers no longer  sell overseas. How about trying  the Forscan forum and enquire there? 

Link to comment
Share on other sites

You'll need FORscan free to download onto a laptop running windows, plus either a V-linker cable or modified usb ELM cable £20-30 depending on which you get.

Link to comment
Share on other sites

There also is a version of Forscan  for Android 

Link to comment
Share on other sites

13 minutes ago, Jimpster said:

You'll need FORscan free to download onto a laptop running windows, plus either a V-linker cable or modified usb ELM cable £20-30 depending on which you get.

Is this will do the job?

A60A1E5E-D3DB-4BC1-908C-AA01B13A57D8.png

Link to comment
Share on other sites


53 minutes ago, Jimpster said:

NO

Can you suggest one I'm based in UK

Link to comment
Share on other sites

Link to comment
Share on other sites

10 hours ago, Vlad2111 said:

Can you suggest one I'm based in UK

It had already been suggested and Unofix has now posted the links, you got a curt NO as certain members on here have the knowledge and should be taken as gospel should you choose to accept it. Mine is ballpark but generally in the right direction as i've read and understand the others.

  • Like 1
Link to comment
Share on other sites

That's so weird. This morning it showed Transmission limited function and I've lost gears 2 and 4. Stopped clear faults with my cheap elm adapter and it's okay now 🤦🏻‍♂️

Link to comment
Share on other sites

All I know about your type of problem I've read about on this forum and strange as it might seem, the egr valve is often the cause of this issue, and NOT the gbox. Something to do with the ecu detecting a power reduction (due to the egr) and reporting it as a power train problem. Maybe focusing your attention to the egr.... remove and clean it maybe...? But you've already said you know nothing about cars so if you're happy to live with it for now....it's your shout! 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership