Jump to content


Photo

Thermostat Problems


  • Please log in to reply
2 replies to this topic

#1 10legend

10legend

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: Fiesta 2001 Zetec
  • Location:

Posted 05 August 2008 - 01:05 PM

Hello all,
I am having major problems with my car, which overheated all of a sudden recently. The problem kept occurring, and so i took it to many garages, all of whom were perplexed by the problem.
So far, the yhave replaced:

Temp Sender Assembly
Thermostat
Anti-Freeze
Water Pump
Radiator
Seal
Heater Control Valve

None of these replacements has fixed the problem. The only way the car now runs is without the thermostat in place at all (a brand new one)...obviously, this is not very efficient, and so i am desperate to solve the problem!

Has anyone got any ideas or had a prob like this before?

Thanks
matt

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,465 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 05 August 2008 - 03:17 PM

was the thermostat replaced the right way round as they are directional ?

#3 10legend

10legend

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: Fiesta 2001 Zetec
  • Location:

Posted 05 August 2008 - 05:08 PM

was the thermostat replaced the right way round as they are directional ?


yes, as it was tried 3 or 4 times with different thermos to see if that was causing the prob...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users