Jump to content


Photo

Windscreen Wiper Problem


  • Please log in to reply
1 reply to this topic

#1 stu 40

stu 40

    Newbie

  • New Member
  • Pip
  • 8 posts
  • Name: Stuart
  • Ford Model: Fiesta S reg
  • Year: 1998
  • Location: Staffordshire

Posted 24 September 2010 - 11:52 AM

Hi. Whilst driving this morning I switched on the windscreen wiper on my S reg Ford Fiesta and the driver's wiper stopped in a vertical position on the return cycle (the passenger wiper returned as normal). When I next switched the wipers on the driver's wiper flipped off the widnscreen! Does anyone know how I can solve this problem?

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,551 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 24 September 2010 - 03:03 PM

it could be wear in the splines of the spigot at the wiper arm base, there should be a nut at the bottomk of the arm which can be removed and the wiper arm pulled of the spigot,then inspect what condition the splines are in,with the wiper arm off operate the wipers and see if the spigot moves, if not the linkage could be damaged.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users