Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
john49

2001 Galaxy Ghia 1.9Tdi Auto

1 post in this topic

Hi, I have been having problems with my auto box for some time now it started as a kick/thump when 5th gear was engaged and went on to reverse gear sometimes not engaging and sounds like the belts slipping when accelerating and then releasing the pedal. I went to a garage last october and they changed the g/box with a reconditioned one (so I was told!) but the problems have come back and of course the waranty has expired. I've noticed on the S-Max forum that they have been having the same problems on their g/boxes and that there may be a problem with the modules communicating with each other and not the g/box needing to be replaced. I 've sent a PM to a member there but if anyone else has some useful info I'd be very grateful.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0