• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


Sign in to follow this  
Followers 0
john49

2001 Galaxy Ghia 1.9Tdi Auto

1 post in this topic

Hi, I have been having problems with my auto box for some time now it started as a kick/thump when 5th gear was engaged and went on to reverse gear sometimes not engaging and sounds like the belts slipping when accelerating and then releasing the pedal. I went to a garage last october and they changed the g/box with a reconditioned one (so I was told!) but the problems have come back and of course the waranty has expired. I've noticed on the S-Max forum that they have been having the same problems on their g/boxes and that there may be a problem with the modules communicating with each other and not the g/box needing to be replaced. I 've sent a PM to a member there but if anyone else has some useful info I'd be very grateful.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0