Jump to content


Photo

I'm Gonna Blow My Car Up!!!!!


  • Please log in to reply
3 replies to this topic

#1 Mitsimatt

Mitsimatt

    Member

  • New Member
  • PipPip
  • 29 posts
  • Name: Matthew
  • Ford Model: FOCUS TDCI
  • Year: 2003
  • Location: Buckinghamshire

Posted 26 November 2011 - 10:08 AM

I have a focus tdci had problems with a injector spent 144 for a recon one fitted it and still running rough takes about 5 mins to start and it smokes so much I have replaced most of the sensors cleaned the egr valve new fuel filter and bg244 and still the same it does have power when it's warm it flys then when slow down again then try too floor it no power goes slow and judders had it on a snap on diagnostic and it keeps saying maf sensor it can't be its new end of my tether what do I do?

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 H3lly

H3lly

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 282 posts
  • Name: k
  • Ford Model: Mk1 Focus
  • Year: 2003
  • Location: Dublin

Posted 26 November 2011 - 11:20 AM

Woah, I can't say I'd blaim you and I can understand your fustration. I would check for a vacuum leak from the breather hose's and air intake. Maybe there is a loose gasket on the inlet manifold or worse case a crack on the manifold itself. If you've only got the egr cleaned maybe it's time to replace it?

#3 Mitsimatt

Mitsimatt

    Member

  • New Member
  • PipPip
  • 29 posts
  • Name: Matthew
  • Ford Model: FOCUS TDCI
  • Year: 2003
  • Location: Buckinghamshire

Posted 28 November 2011 - 07:51 PM

Found the problem piston rings gone on 1&2 f##king car gonna get a new engine for 456 pounds with 3 months warranty on it all I need before Xmas.

#4 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 21,148 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 30 November 2011 - 07:01 PM

Out of curiosity where did you get a used engine and 3 months warranty from?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users