Jump to content


Photo

Front/rear/windscreen Heater And Hazards Not Working


  • Please log in to reply
2 replies to this topic

#1 Tony's mondy

Tony's mondy

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Name: Tony
  • Ford Model: Mondeo 1.8 ghia diesel
  • Year: 2008
  • Location: Yorkshire

Posted 18 February 2012 - 04:11 PM

Hi all, newbie to the site, my front/rear windscreen heaters not working also hazards, when I pressed relavant buttons nothing happens, could it be a fuse problem? If so which fuse box do I go to and what size fuse am I looking for, Mondeo mk4 1.8 ghia diesel 08 plate.
I would have referred to Haynes manual but they are not available at the moment, any help would be appreciated
Thanks
Tony.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,466 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 18 February 2012 - 09:36 PM

all the fuse and relay info can be found in the first link here.

http://www.google.co...formation - Mk4

#3 Tony's mondy

Tony's mondy

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Name: Tony
  • Ford Model: Mondeo 1.8 ghia diesel
  • Year: 2008
  • Location: Yorkshire

Posted 19 February 2012 - 08:55 AM

Hi, many thanks for the info, unfortunately I could not see fuse relating to hazards, will continue to search elsewhere.
Cheers
Tony


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users