Jump to content


Battery Light Came On And Power Steering Died.

  • Please log in to reply
4 replies to this topic

#1 bungral



  • New Member
  • PipPip
  • 14 posts
  • Name: Marc
  • Ford Model: Focus
  • Year: 2003
  • Location: London

Posted 07 April 2012 - 12:58 PM

I was driving my girlfriend to a train station this morning and on the way there I felt my power steering fail and saw that the battery light had come on. (Ford Focus 1.6 Zetec-SE 2003)

This lasted for about 10 - 15 seconds and then it came back on and the rest of the journey was ok.

I recently upgraded the speakers in my front doors and they are running off an AMP in the boot but they shouldn't have been drawing too much power even though I was listening to music at a reasonable level yesterday for around 90 mins while driving.

If that had sucked some charge from the battery, I would have thought I would have experienced problems starting it this morning? It started without fault today.

I've just checked the voltages as follows:

Ignition off - 12.5v
Idling + heated rear window and dipped beams (With 3 pin smart charge system plug on alternator in) 13v
Idling + heated rear window and dipped beams (With 3 pin smart charge system plug on alternator unplugged) 15v

From that I gather that the smart charge system is still functioning as it should and that the alternator is working.

Could it be that the battery is possibly on its way out and while running it discharged enough for the light to come on?

The battery in there is an OEM Motorcraft battery. Does this imply it's been there since new? If so I could believe that it's on its way out as the car is an 03 plate!!

Any help would be great.


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Stoney871


    Resident Peacekeeper

  • Super Mod
  • 19,635 posts
  • Name: Clive
  • Ford Model: 2015 Focus ST3 250BHP
  • Year: 2015
  • Location: Devon

Posted 07 April 2012 - 03:17 PM

I'd contemplate getting a new battery due to it's age but get it tested at a garage/battery fitter first.

#3 jay1981


    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 170 posts
  • Name: James
  • Ford Model: Focus Zetec 1.8 TDCI
  • Year: 2009
  • Location: Devon

Posted 07 April 2012 - 06:00 PM

A Motorcraft battery is an OEM fit, so probably original. The battery light on the dash means that there is a fault in the charging circuit not with the battery itself.

With all electrical items off you should get about 14.5 volts with the engine idleing, and the smart charge plug connected. It sounds like the alternator is charging OK. Did you drive through a deep puddle beforehand? This can make the Aux belt slip causing the battery light and the loss of power steering.

I would check that the aux belt and tensioner is OK, I wouldn't rush out and buy a new battery.

#4 artscot79


    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 8,165 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 07 April 2012 - 07:14 PM

ide look at the wiring for the amp first and the speakers strange you change these and get issues is the amp switching off fully when the cars off

#5 jeebowhite


    Resident Loon

  • Super Mod
  • 22,296 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent

Posted 11 April 2012 - 01:08 PM

Batteries that surpass 5 years have done well for themselves, from about 6 years they can start giving a few flaky results. for the price of £100 to replace the battery, or much more to replace the alternator, its worth going down the line of battery first!

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users