Jump to content


Photo

Mondeo Tdci Wrong Injector Or Ripped Off???


  • Please log in to reply
4 replies to this topic

#1 martinstone

martinstone

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: mondeo zetec s
  • Location: Yorkshire

Posted 24 April 2013 - 08:34 AM

hello, i have a mondeo tdci 130 zetec-s, cut out problem found fuel pump, replaced pump and injectors all lines and tank sorted etc, so car wouldnt start which i knew it wouldnt so my friend came with his snap on system to programme injectors,,, now it has connected before but this time it wont read the ecu or even reconize its connected to the car??? so i checked the injectors i had fitted and found them to be code 301z now i need 501z so my question is would the wrong injectors cause the ecu to not be read? i know i need to change injectors which are on the way, but why will the code reader not connect to the car? can someone shine any light on this matter? code reader works on all other cars so not faulty and has programmed the injectors previously? all help is appreciated many thanks 



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 martinstone

martinstone

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: mondeo zetec s
  • Location: Yorkshire

Posted 24 April 2013 - 03:52 PM

CAN ANYONE SHED ANY LIGHT? PLEASE



#3 wase16ll

wase16ll

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,133 posts
  • Name: Tony
  • Ford Model: granada
  • Year: 1992
  • Location: Greater London

Posted 24 April 2013 - 09:15 PM

could be a number of reasons, most likely fuse or wiring problem on car.
you can buy data link connector testers that will give an instant assesment of your 16 pin connectors wiring...will flash up an led if something isnt right....or alternatively you need to manually check the connector with a volt meter.

#4 martinstone

martinstone

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: mondeo zetec s
  • Location: Yorkshire

Posted 25 April 2013 - 08:15 AM

problem was a blown fuse thankyou wase16ll now problem is the replacement injectors supplied are 301z mine were 501z am i correct in thinking these will not work in my engine due to nozzles been too long?



#5 Avenger1978

Avenger1978

    Settling In Well

  • New Member
  • PipPipPip
  • 47 posts
  • Name: mark
  • Ford Model: Mondeo Ghia x 130 diesel
  • Year: 2003
  • Location: Leicestershire

Posted 14 May 2013 - 08:20 PM

 301z are for the focus  and the 501z are for the mondeo...... `301z have longer noozles to the 501z




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users