Jump to content


Photo

Fiesta 1.4 Tdci Running Rough


  • Please log in to reply
2 replies to this topic

#1 Lastout

Lastout

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: Jason
  • Ford Model: Fiesta 1.4 TDCI
  • Year: 2002
  • Location: Aberdeenshire

Posted 13 May 2013 - 05:27 PM

Hi all I'm looking for a little help.

 

I have a fiesta 1.4 TDCI 2002, I had on of the injectors replaced a couple of weeks ago and it hasn't been running right.

As soon as you hit between 2,000 and 3,000 RPM runs rough, if you push past 3,000 it runs just fine.

 

any idea's?

 

Thanks,



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 DanGersFord

DanGersFord

    Dan The Gas Man

  • FOC Supporters
  • 3,498 posts
  • Name: Daniel
  • Ford Model: Fiesta ST3
  • Year: 2014
  • Location: Scotland
Contributor

Posted 13 May 2013 - 06:35 PM

Was it the right injectors you fitted? Sure they're meant to be coded

#3 Lastout

Lastout

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: Jason
  • Ford Model: Fiesta 1.4 TDCI
  • Year: 2002
  • Location: Aberdeenshire

Posted 13 May 2013 - 08:38 PM

I left it to the garage to order and  fit so all I can do is hope they ordered the right one.  They did tell me that they had it on the computer before I got it back.




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users