• Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


wayne

MK3 MONDEO ENGINE MANAGEMENT LIGHT

4 posts in this topic

around 5 weeks ago my engine management light came on whilst driving the still drove perfectly got home took battery off for 30 mins connected it back up the light as stayed off untill today when its come on again whilst driving i took battery off again drove the car too work and back and to the supermarket and its fine the lights stayed off...whats causing it to come on like i say its 5 weeks since it last happend but the car drives perfect ..what i have noticed is its using more fuel could it be the lambda sensor but theres two sensors one on the down pipe which looks difficult to remove and one just after the cat which looks easier????..is this my problem??

Share this post


Link to post
Share on other sites
 

Hi wayne,

have a diagnostic check done, as you've had a fault returning it will be stored in ecu. be cheaper to to this than guess which lamda it is..

steve

www.sr-performance.co.uk

Share this post


Link to post
Share on other sites

HI,

Rule of thumb on the mondeo

if the glow plug light comes on or flashes then its fuel related or injectors that side of the system

if the mil light comes on then its air leak or sensor gone

Share this post


Link to post
Share on other sites
around 5 weeks ago my engine management light came on whilst driving the still drove perfectly got home took battery off for 30 mins connected it back up the light as stayed off untill today when its come on again whilst driving i took battery off again drove the car too work and back and to the supermarket and its fine the lights stayed off...whats causing it to come on like i say its 5 weeks since it last happend but the car drives perfect ..what i have noticed is its using more fuel could it be the lambda sensor but theres two sensors one on the down pipe which looks difficult to remove and one just after the cat which looks easier????..is this my problem??

yes it is the the first sensor on the downpipe tells the ecu the fuel to air ratio mix the second sensor after the cat tells the ecu that the cat is ok as it will sens how much co it produces out

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now