Jump to content


Photo
- - - - -

Front Passenger Footwell Water Leak


  • Please log in to reply
1 reply to this topic

#1 holiday

holiday

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Fiesta LX 1.25
  • Location:

Posted 03 February 2009 - 10:49 PM

Hi
Having trouble with water leaking into footwell when parked. This fault appears to have occured very recently. Started noticing problem with ice inside of windscreen, then after heavy rain carpet was swimming. Removed trim in side of footwell and water running down cables. Traced to rubber gromets in bulkhead behind fuse box. Cleaned them up and re fitted with silicon grease. Checked pollen filter cover seems OK. Got hose pipe out still leaking. Any other ideas

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 ste

ste

    Member

  • New Member
  • PipPip
  • 25 posts
  • Ford Model: xr2i 16v
  • Location:

Posted 04 February 2009 - 07:16 PM

Hi
Having trouble with water leaking into footwell when parked. This fault appears to have occured very recently. Started noticing problem with ice inside of windscreen, then after heavy rain carpet was swimming. Removed trim in side of footwell and water running down cables. Traced to rubber gromets in bulkhead behind fuse box. Cleaned them up and re fitted with silicon grease. Checked pollen filter cover seems OK. Got hose pipe out still leaking. Any other ideas

hi pall check the gromit were the speeker wires go through to doors i ran a power cable thru this and had same prob


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users