Jump to content


Show
Photo
- - - - -

New Fiesta Ecoboost Issue?


  • Please log in to reply
10 replies to this topic

#1 jd_james

jd_james

    Feet Under The Table

  • FOC Supporters
  • 179 posts
  • Name: James
  • Ford Model: Fiesta Ecoboost Zetec S
  • Year: 2013
  • Location: West Midlands

Posted 19 April 2013 - 06:44 PM

Have driven the car little over 1000 miles in a month and in two days ive noticed a burning smell.

 

This first happened yesterday and then again today. Now on both occasions the engine has been warm and at optimum temperature and I have not been using the clutch excessively  The engine bay was naturally very warm after being used for the past 20 minutes.

 

The burning smell was coming from inside the car, a burning plastic or rubber smell.

 

I have smelt a burning clutch before which was like rotten vegetables - this didn't smell like that.


Has anyone else experienced anything similar?

 

I will take it into the servicing garage at ford if this carries on - ill give it a week!

 

James



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 bigmunkynutz

bigmunkynutz

    Slightly Addicted now...

  • FOC Supporters
  • 347 posts
  • Name: Stephen
  • Ford Model: Fiesta Mk7.5 ZS 125PS+
  • Year: 2013
  • Location: Cheshire

Posted 19 April 2013 - 08:45 PM

Not to alarm you too much but this could be electrical, I'd consider taking it to ford as soon as you can just to be on the safe side.

#3 jd_james

jd_james

    Feet Under The Table

  • FOC Supporters
  • 179 posts
  • Name: James
  • Ford Model: Fiesta Ecoboost Zetec S
  • Year: 2013
  • Location: West Midlands

Posted 19 April 2013 - 11:29 PM

Dont say that! I've got to drive that car to Peterborough Sunday!



#4 Marcr1

Marcr1

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 976 posts
  • Name: Marc
  • Ford Model: S1600
  • Year: 2012
  • Location: Wales

Posted 20 April 2013 - 07:04 AM

It's probably nothing to worry about. The car is still new and now that you've done 1000 miles you're probably driving it a bit harder / more like you usually do. It sounds like the car still bedding in, mine made smells at the 2000 mile mark if I pushed it a bit harder than normal

#5 b1g_dav3

b1g_dav3

    Ford Enthusiast

  • Moderator
  • 2,516 posts
  • Name: David
  • Ford Model: Fiesta Zetec S TDCi
  • Year: 2013
  • Location: Lancashire
Contributor

Posted 20 April 2013 - 08:37 AM

Might find a few things smell funny as it's run in, it's normal really, and usually you overreact because you don't expect anything off a new car smell wise.



#6 Sliveredge

Sliveredge

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 89 posts
  • Name: Peter
  • Ford Model: mk7.5 fiesta 1.0 125 titanium x
  • Year: 2013
  • Location: Kent

Posted 20 April 2013 - 09:08 AM

mine does this now and then I have 1700 miles on the clock I will be popping it in to ford next week for its after delivery check and mentioning it along with the annoying indicators that like to to cancel early rather annoying!!

#7 MartynS

MartynS

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,030 posts
  • Name: Martyn
  • Ford Model: Fiesta ST2
  • Year: 2013
  • Location: Hampshire

Posted 20 April 2013 - 11:38 AM

annoying indicators that like to to cancel early rather annoying!!

My 2010 Zetec-S has always done this, I'm often turning them back on at roundabouts!  More annoying though is when you switch from the right to left coming off a roundabout and it decides to wait a moment before actually flashing the left one.



#8 E5GDM

E5GDM

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 424 posts
  • Name: Gary
  • Ford Model: Zetec S
  • Year: 2013
  • Location: Essex

Posted 20 April 2013 - 03:35 PM

My car smells the same....I'm putting it down to the coating on the exhust etc burning off.

#9 Lukem30

Lukem30

    Member

  • New Member
  • PipPip
  • 17 posts
  • Name: Luke
  • Ford Model: Fiesta zetec s 1.0
  • Year: 2013
  • Location: Caerphilly

Posted 20 April 2013 - 04:35 PM

Mine had a burning smell on the way home, I put I down to having the radio on full chat straight away

#10 jd_james

jd_james

    Feet Under The Table

  • FOC Supporters
  • 179 posts
  • Name: James
  • Ford Model: Fiesta Ecoboost Zetec S
  • Year: 2013
  • Location: West Midlands

Posted 20 April 2013 - 05:26 PM

How could it be the exhaust when you smell it in the interior?

 

Admittedly I dont think its from the air vents



#11 E5GDM

E5GDM

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 424 posts
  • Name: Gary
  • Ford Model: Zetec S
  • Year: 2013
  • Location: Essex

Posted 20 April 2013 - 09:43 PM

How could it be the exhaust when you smell it in the interior?



Not exhaust fumes, but fumes from the coating burning off along the entire length of the exhaust.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users