Fordist

Dashboard Lights

Recommended Posts

Hello everyone!

I have a problem with my Ford C-max diesel 2011. A few minutes (app. 5-7 minutes) after I start the vehicle, all the light on the dashbord light up (oil, engin, security belt, hand brake, ABS, hill, servo, slipping...) literaly all the lights that exist, speedometer, tachometer, milleage counter (trip computer) do not work either...the only thing that work is fuel level and engin temperature... The vehicle runs "normally", besides that the steering wheel is a bit stiff (not too much)... The dashboard cluster has been replaced, the error persists, ABS has been replaced, the error persists... When I turn off the vehicle and start it again, only the engin light stays on (sometimes oil light too), the third time I turn off the vehicle, no light is turned on, everything seems normal, then the next time I start the vehicle, all lights are on again. Sometimes when I turn off the vehicle and I lock it, front car lights do not turn off and I have to lock it several times in order to turn off the lights. 

 

Any ideas what it might be?

Webp.net-resizeimage.jpg

Share this post


Link to post
Share on other sites
 

2 minutes ago, pragmatix said:

Hows the battery, how old?

battery should be ok, it starts every time without a problem... I can get it checked...

Share this post


Link to post
Share on other sites

A low battery can start the car ok but throw up all sorts of problems worth checking the alternato too, if a phase hase gone down it can give faults but look ok if checked with a multimeter.

Also have you had fault codes read?

Not sure if the model share its instuments with the Focus which often gets binnacle faults.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now