Jump to content
Do Not Sell My Personal Information


Urgent help? With my focus 2017


Recommended Posts

Hello, 

I have had an engine service now light on my dash then the car went into limp mode.

took it to Ford and they said that the car needs a new dpf and turbo. 
I have instead cleaned out the whole dpf from a specialist which I had to take out the dpf it’s self. Since then I have put the dpf back on and also the changed the turbo and the car starts but when I Rev it it’s hitting 3000 revs that’s it and still in limp mode? Have took it to multiple mechanics and they said they haven’t got a clue what’s up with my car this is stressing me out and I don’t know what to do. Has any one have this sort of problem before ?

it’s a focus 1.5 tdci diesel.

 

Link to post
Share on other sites

Yes I have but it’s coming up dpf and mass air filter but the mechanic said that the dpf is not the problem also the mass air Is working fine.  He checked the whole engine for any split hoses or any leaks but they all seem to be fine, 

even did a regen about 5x but only loads up to 89% then cuts out. But the car is still limp and no boost at all. The air intake pipe is soft and you can squeeze the pipe even when am revvin or on idle. It suppose to b hard not soft 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership