Stevie w

Engine light

Recommended Posts

Hi all 

I've bought a 51 plate puma

ive been informed that the engine light is on because it's running LEAN 

any ideas what the problem is ?

Share this post


Link to post
Share on other sites
 

Hi does this car have a secondary air pump if so that could be your problem 

Share this post


Link to post
Share on other sites

Where will that be situated?

the car drives really well just the light is on I've taken it off but after 5 days off it came back on

Share this post


Link to post
Share on other sites

I'm not sure on a puma if it has one what is the code you are getting I have a galaxy and when I plugged it in I could see it was always running in open loop lean which was down to the pump not running its there to heat the cat up quicker and because it was not seen to be running left the car in open loop all the time and putting the engine light on 

Share this post


Link to post
Share on other sites

I have been informed it's the Lambda sensor 

but then I've also been told about someone who changed that and still the light stayed on 

Share this post


Link to post
Share on other sites

Well you have 2 choices replace the sensor of buy a scanner to get the code very cheap on ebay 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.