Jump to content
Do Not Sell My Personal Information


Focus mk1.5 VSS (speed sensor)


JoJbL
 Share

Recommended Posts

Hy guys.

At first sorry for my language, I'm from Slovenia ;)

Focus 2004 1.6 petrol 74kW

So, I had faulty VSS (speed needle dropping to 0) and I replaced it with new aftermarket sensor. There comes new problem :D The speed needle is waveing/oscilating for about 5-10km/h (attached gif). I tried to replace it with another new sensor (other manufacturer) and still same problem. Forscan did found 2 DTCs: P1000 and P0723.

I already did clean contact, try to find some faulty cable, but no luck.

I also attached PrtScr from Forscan live, if it helps (VSS, VSS_OBD, OSS).This was recorded barely moving.

Any suggestions what should try to fix?

 

Regards, Martin

ezgif.com-video-to-gif.gif

OSS.png

Link to comment
Share on other sites

Did you keep a note of the old codes before you did a reset? As P1000 suggest someone clear some old codes, pending or stored. 

P0723 - would suggest you have a wiring issue or sensor issue. As you stated you have change the sensor twice, that would mean you have some wiring tracing to do. You need to see if any wiring has been damaged or kinked. As the signal is intimate you need to check wiring. 

You could also try going over a bump or harsh road and see what the needle does then.

Or something that is shouldn't be but could be a issue is the connector is either not on correctly to the sensor or is worn out, or broken locking tab. 

Link to comment
Share on other sites

  • 2 weeks later...

Wiring is checked, but everything seems to be OK.
I don't know how the transmission looks from inside where the sensor is placed, is there possible that I damaged something when I was pulling the sensor out, because I was revolving/turning it?

Poslano z mojega WAS-LX1 z uporabo Tapatalk

Link to comment
Share on other sites

  • 4 months later...

We find out, that the ring inside the gearbox, where the sensor reads the revs of the shafts from, is plastic and was deameged. So I changed the gearbox (it was easier and cheaper than repair) and now it works great.

Regards

Poslano z mojega WAS-LX1 z uporabo Tapatalk

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership