Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Richaj

Problems With Bluetooth Audio

125 posts in this topic

Just got my 2011 Fiesta with Bluetooth kit and iPod USB connection. I am running an iPhone 4 with ios 5 on it and am having a lot of issues with the audio over Bluetooth.

I get a message saying "BT audio error reading device" quite often. Also the Bluetooth appears to disconnect after 20-30 mins with no sound coming out and the only way to fix it is to reconnect the phone. Also have problems when changing from phone to audio as it becomes choppy and te only way to fix is to again to reconnect to the phone. Finally I have read that iOS 5 should output track names and see that people have go this working in here but it doesn't work for me.

Does anyone know what the problems may be. I am fairly sure that it is a ford software issue but don't know how to check the version that I have and how to update it.

Share this post


Link to post
Share on other sites
 

What version of iOS 5 Beta are you running?

Share this post


Link to post
Share on other sites

Running beta 7 but have had problems with 5 & 6 too.

Share this post


Link to post
Share on other sites

Does it work ok with the previous version? (4?)

Share this post


Link to post
Share on other sites

Not really tried it fully but it does appear that it is there in 4.3.4 as it cut out as well.

Share this post


Link to post
Share on other sites

Got any mates with an iPhone to test and rule it out?

Share this post


Link to post
Share on other sites

Will Have another go

Share this post


Link to post
Share on other sites

Running iphone 4.3.5. works fine for me. I just switch phone bluetooth on. Get in car, switch radio on, wait for them to bond and off we go. Music, calls, podcasts. Cant see any info on display tho. I take it you have switched bluetooth on in car and then bonded them?? silly question I know but!!......It may be new bluetooth software in new fiesta. Or beta software not upto scratch yet.

Share this post


Link to post
Share on other sites

The beta softwares fine, I had a few issues with iOS 5 beta 1 but from 2 onwards it's been fine and all track info displays as should over bluetooth..

Have you tried anyone elses phone? Either iPhone or something different?

If theirs work then it's your phone if they don't you know what's broken :)

If its your iPhone that's the issue I'd recommend flashing back to 4.3.5 and trying that, if that don't work back to apple you go :)

Share this post


Link to post
Share on other sites

I can get music for short periods of time but then cuts out. If I use the forward or reverse button I get the BT audio error. I have completely reset my phone overnight and will try again and then try with 4.3.5.

How do I tell if the radio has latest software installed?

Share this post


Link to post
Share on other sites

The reset made no difference at all. Will try another phone with ios 5 and also 4.3.5.

Any help in understanding the radio software is appreciated.

Share this post


Link to post
Share on other sites

How do I tell if the radio has latest software installed?

Take it to the dealer.

Share this post


Link to post
Share on other sites

It is now all fixed. All down to requiring a new software update for the radio.

Share this post


Link to post
Share on other sites

It is now all fixed. All down to requiring a new software update for the radio.

Does this have to be done by the dealer, or can it be downloaded and updated via USB?

Lenny likes this

Share this post


Link to post
Share on other sites

Does this have to be done by the dealer, or can it be downloaded and updated via USB?

A dealer will need to hook your car up to an IDS machine to see if there is an applicable update for your car..how old is your car?

On another note, I knew you were going to comment on this thread (I just saw your topic on the Macrumors site) lol

I havent had any problems with my bluetooth (calls or music) in my fiesta since iOS 5 Beta 2 onward, may not have used it long enough to cause any though

Share this post


Link to post
Share on other sites

Here is what i get when my iPhone 3GS is connected and playing music - running iOS5

It will happily play the music still, but every time i change tracks, it comes up with the error - yet still play the song...

22dfc1a4.jpg

Share this post


Link to post
Share on other sites

Tried my iPhone 4 running iOS5 just there and had no problems connecting via BT however got no track names.

Share this post


Link to post
Share on other sites

A dealer will need to hook your car up to an IDS machine to see if there is an applicable update for your car..how old is your car?

On another note, I knew you were going to comment on this thread (I just saw your topic on the Macrumors site) lol

I havent had any problems with my bluetooth (calls or music) in my fiesta since iOS 5 Beta 2 onward, may not have used it long enough to cause any though

:angry: I hate being predictable....

The car has just celebrated it's first birthday, so not exactly old. I've not tried using it for calls over the BT connection yet, so I don't know if that has the same effect. So are you now running the full version of iOS 5, not a Beta version? I'd have thought the length of time it's been used for would be irrelevent - mine started playing up literally half an hour after I'd finished installing iOS 5. 'Tis annoying.

Share this post


Link to post
Share on other sites

Yeah I've had iOS 5 all through the Betas to Public Release and only had issues in Beta 1..

Take it too Ford as there will have been updates within the last year you've had the car

Share this post


Link to post
Share on other sites

My iphone 4 is running ios 5 (offical) and I am getting track names displayed.

Share this post


Link to post
Share on other sites

I got the 4S, no track names were displayed, then after a few songs it came up error reading device and wouldn't play anymore

Share this post


Link to post
Share on other sites

I had the same thing with the iPhone 4s, songs would play but error and eventually just stop working, took my car to Fords, they updated the software and its fine now.

Bluetooth names are displayed, i can shuffle, repeat etc from bluetooth now too. Also i can listen to music by just plugging in the USB to my phone, in the past i neeeded the AUX cable to do this so all very happy with the update!

Share this post


Link to post
Share on other sites

I had the same thing with the iPhone 4s, songs would play but error and eventually just stop working, took my car to Fords, they updated the software and its fine now.

Bluetooth names are displayed, i can shuffle, repeat etc from bluetooth now too. Also i can listen to music by just plugging in the USB to my phone, in the past i neeeded the AUX cable to do this so all very happy with the update!

Very interesting indeed! Could I ask which head unit you've got in the car and which model/ year car?

Ive got the 4s now and am still getting the errors mentioned in this thread. i think ill give the Garage a call.

Share this post


Link to post
Share on other sites

I have the standard head unit in a 10 plate fiesta, zetec. It's not the Sony one or anything.

I would call them and make sure it's running the latest software. It's a shame there's no way for us to do the update our selves

Share this post


Link to post
Share on other sites

I've got the Sony head unit in a March 2011 titanium. I don't think I'd have any joy asking the dealer to update the software. I asked them to do that at my first service for my previous Zetec and they said they didn't know what I was talking about.

Back to using the cables I think :angry:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now