Sign in to follow this  
pnroyal

Engine locked up Mk 2 Focus.

Recommended Posts

I just changed the auxilliary belts, when I put it all together the engine is locked, I can rotate it by hand about 30 degrees and it stps with a 'thunk' each way. Any ideas?

We took the sump off and it looks ok, the cam chain is intact, we detimed the engine and there is still no more rotation available. Its like something is obstructing the crankshaft....but with a thunk not a wedging effect.

Share this post


Link to post
Share on other sites
On 5/18/2020 at 12:51 PM, pnroyal said:

I just changed the auxilliary belts, when I put it all together the engine is locked, I can rotate it by hand about 30 degrees and it stps with a 'thunk' each way. Any ideas?

We took the sump off and it looks ok, the cam chain is intact, we detimed the engine and there is still no more rotation available. Its like something is obstructing the crankshaft....but with a thunk not a wedging effect.

What engine is it?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this