Jump to content
Do Not Sell My Personal Information

Mondeo MK4 radio keycode entry buttons not working

Recommended Posts

Hi All, i have a Mondeo MK4 where my head unit stopped powering up so i have purchased another identical head unit and i have the code for it, i have fitted the radio and when it asks for the code none of the buttons work, and then sometimes the number 1 button will work but no other buttons will work, not even the delete option,i have searched but not found any instructions on any special way to enter the code on this perticular head unit, i will list the things i have tried so you know what it isn't, i will also show a picture of the head unit.


*press buttons and nothing happens.

*pressed button 1 for code number entry 1,then pressed 1 again to increase the 1 to a 2 or higher, the 1 just goes to the 2nd code entry so i have 1-1.

*tried the above and tried using the volume up and down switch to increase/decrease the number, nothing happens,tried the skip forwards/backwards to increase/decrease number, nothing happens.tried the up and down switches on the steering wheel nothing happens.

*Instead of pressing 1 first i have tried pressing other numbers and nothing happens.

*i have powered the car off and tried the above, i have had the key in all ignition positions and tried the above.

*i have pressed button 1 to enter the first number of the code (which is 1) then pressed the next number and nothing happens.


if anyone has the same radio and has the same issue or knows exactly how this one needs to be entered i would be forever thankful for any assistance.


Link to comment
Share on other sites

This is what the manual says:


If CODE - - - -, CODE 0000, SAFE or
ENTER KEYCODE appears in the
display when you switch on the unit, you
must enter the Keycode using the on
screen instructions.
Use the number buttons to enter the
correct code. Press the button below OK
to confirm the entry.
Make sure that you have entered the
correct Keycode before confirming
the entry. Repeated incorrect entries
may cause a permanent lock of the unit.
Up to three Keycode entry attempts are
allowed before the unit will lock for one

Link to comment
Share on other sites

thanks ris but i have that manual and tried that but it didnt work, thats where i found that other models have different ways of entering the code


Link to comment
Share on other sites

I think the simplest reason is that the unit you purchased is sadly faulty....

My 1st port of call would be a return visit to the seller and hope they don't wash their hands of it.

Link to comment
Share on other sites

So a bit of an update, i have changed the whole button assembly (from my original unit which i know for a fact worked) into the new radio to cover any possibility that the buttons are faulty, and when i say the whole assembly i do mean the whole assembly, and great news, its done nothing, the same thing is happening so i know it isn't faulty buttons, i will show pictures of the parts i changed.


IS THERE ANYONE WHO HAS THIS EXACT SAME STEREO THAT HAS ENTERED A CODE????? i cant help but think there is an unusual sequence that needs to be used.


On the chance that it is a more internal issue i am going to be trying the following things;

*Swap the new radios screen to my old radio parts to see if that powers up, if not then..

*swap the power pack part of the old radio for the power pack part of the new radio.




  • Sad 1
Link to comment
Share on other sites

Thanks unofix, I have tried both of those ways and neither has done anything, still stuck with only the number 1 being active sometimes.


  • Sad 2
Link to comment
Share on other sites

4 hours ago, Dave80 said:

still stuck with only the number 1 being active sometimes.

Then I have to say I think your replacement unit is just as dead as your original. 🙁

Looks like you need to get one of the units sent away for repair.


Link to comment
Share on other sites

update, SUCCESS!!!! EUREKA!!!! TFIDI (thank f@~# i did it.)


ok i now have a working radio and i will go through the process that brought me success,

*first of all there is no clever sequence.

*second it appears i did have 2 faulty units but swapping the right parts is what brought the success.

*my original unit the large part of it, the power pack part i am calling it was defo dead.

*the part that was faulty on the new unit was one of the circuit boards which i will show with a picture.

*the buttons were not faulty on either unit.

*i am unsure if the screen on my original unit is faulty.

*i have taken the button assembly from my original unit, the circuit board that attaches to it from my original unit (this is they key fix piece), the screen from the new unit and the power pack from the new unit.

*i tried the above but with my original power pack but it would not power up, thats how i know its defo dead.

*the key piece as mentioned above is the circuit board that connects direct to the button assembly, i hadnt changed that before because i thought it would not work with a different power pack, how wrong i was.

*so the old buttons, the newer screen and power pack, connect it up, attempt to enter the code from the new unit and the buttons worked as they should.



*press the number of the first digit of the code

*press the number of the second digit of the code

*press the number of the third digit of the code

*press the number of the fourth digit of the code

*press ok, then ***** off the neighbours yelling in celebration like whats his face from madagascar when he creates fire.


clearly i was unlucky having two faulty units but thank you to all for your suggestions, 


as a side note, if anyone has this radio and it does not power up, you might find your car battery starts to get drained, mine did, within a few days it was dead, it took me weeks to work out that the radio was drawing power and i was unable to turn it off because it was never on to be turned off, the only way to stop it draining the battery was to disconnect the radio from the power supply. then get a newer radio and have the ball ache that i had.


anyway job done, thanks again.






  • Like 3
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...